CISCO

CONFIGURING RIP (ROUTING INFORMATION PROTOCOL)


ASSIGN IP ::
R1:::
config t
int s0/0
ip add 192.168.12.1 255.255.255.0
no sh
exit
int s0/1
ip add 192.168.13.1 255.255.255.0
no sh
exit
R3:::
config t
int s0/0
ip add 192.168.35.3 255.255.255.0
no sh
exit
int s0/1
ip add 192.168.13.3 255.255.255.0
no sh
exit

R2:::
config t
int s0/0
ip add 192.168.12.2 255.255.255.0
no sh
exit
int s0/1
ip add 192.168.24.2 255.255.255.0
no sh
exit

R4:::
config t
int s0/1
ip add 192.168.24.4 255.255.255.0
no sh
exit

R5:::

config t
int s0/0
ip add 192.168.35.5 255.255.255.0
no sh
exit
R5:::

config t
router rip
no auto-summary
network  192.168.35.0
exit
CONFIGIRING RIP :::

R1:::

config t
router rip
no auto-summary
network  192.168.12.0
network  192.168.13.0
exit
CONFIGURING MD5 BETWEEN  R1 AND R2::

R1:::

Config t
Key chain kc1
Key 1
Key-string cisco123
Exit
Exit
Int s0/0
Ip rip authentication  mode md5
Ip rip authentication key-chain kc1
End
R2:::

config t
router rip
no auto-summary
network  192.168.12.0
network  192.168.24.0
exit
R2:::

Config t
Key chain kc1
Key 1
Key-string cisco123
Exit
Exit
Int s0/0
Ip rip authentication  mode md5
Ip rip authentication key-chain kc1
End
R3:::

config t
router rip
no auto-summary
network  192.168.13.0
network  192.168.35.0
exit
VERIFY:::

Sh ip routes
Sh ip routes rip, sh ip protocols,



CONFIGURING EIGRP (ENHENCED INTERIOR GATEWAT ROUTING PROTOCOL)



ASSIGN IP ::
R1:::

config t
int s0/0
ip add 192.168.12.1 255.255.255.0
no sh
exit
int s0/1
ip add 192.168.13.1 255.255.255.0
no sh
exit
R3:::
config t
int s0/0
ip add 192.168.35.3 255.255.255.0
no sh
exit
int s0/1
ip add 192.168.13.3 255.255.255.0
no sh
exit

R2:::
config t
int s0/0
ip add 192.168.12.2 255.255.255.0
no sh
exit
int s0/1
ip add 192.168.24.2 255.255.255.0
no sh
exit
R4:::
config t
int s0/1
ip add 192.168.24.4 255.255.255.0
no sh
exit

R5:::
config t
int s0/0
ip add 192.168.35.5 255.255.255.0
no sh
exit

R4:::
config t
router eigrp 100
no auto-summary
network  192.168.24.0 0.0.0.255
exit

VERIFY::::

sh ip route 
R5:::
config t
router eigrp 100
no auto-summary
network  192.168.35.0 0.0.0.255
exit
CONFIGIRING EIGRIP :::

R1:::

config t
router eigrp 100
no auto-summary
network  192.168.12.0 0.0.0.255
network  192.168.13.0 0.0.0.255
exit


CONFIGURING MD5 AUTH BETWEEN R1 AND R2:::
R1:::

Config t
Key chain  kc1
Key 1
Key- string cisco123
Exit
Int s0/0
Ip authentication mode eigrp  100 md5
Ip authentication key-chain eigrp  100 kc1
End
R2:::

config t
router eigrp 100
no auto-summary
network  192.168.12.0 0.0.0.255
network  192.168.24.0 0.0.0.255
exit

R2:::
Config t
Key chain  kc1
Key 1
Key- string cisco123
Exit
Int s0/0
Ip authentication mode eigrp  100 md5
Ip authentication key-chain eigrp  100 kc1
End
R3:::
config t
router eigrp 100
no auto-summary
network  192.168.13.0 0.0.0.255
network  192.168.35.0 0.0.0.255
exit



CONFIGURING OSPF(OPEN SHORTEST PATH FIRST) 


Assign Ip:::

R1::
Config t
int s0/0
ip add 192.168.12.1 255.255.255.0
no sh
exit
int s0/1
ip add 192.168.13.1 255.255.255.0
no sh
exit
int lo0
ip add 192.168.1.1 255.255.255.0
no sh
exit


R2::

Config t
int s0/0
ip add 192.168.12.2 255.255.255.0
no sh
exit
int s0/1
ip add 192.168.24.2 255.255.255.0
no sh
exit
int lo0
ip add 192.168.2.2 255.255.255.0
no sh
exit


R3::

Config t
int s0/0
ip add 192.168.35.3 255.255.255.0
no sh
exit
int s0/1
ip add 192.168.13.3 255.255.255.0
no sh
exit
int lo0
ip add 192.168.3.3 255.255.255.0
no sh
exit

R4::

Config t
int s0/1
ip add 192.168.24.4 255.255.255.0
no sh
exit
int lo0
ip add 192.168.4.4 255.255.255.0
no sh
exit

R5::

Config t
int s0/0
ip add 192.168.35.5 255.255.255.0
no sh
exit
int lo0
ip add 192.168.5.5 255.255.255.0
no sh
exit



CONFIGURING OSPF:::

R1::

Config t
router ospf 1
network 192.168.12.0 0.0.0.255 area 1
network 192.168.13.0 0.0.0.255 area 1
network 192.168.1.0 0.0.0.255 area 1
passive-interface lo0
end


R2:::

router ospf 1
  network 192.168.12.0 0.0.0.255 area 0
  network 192.168.24.0 0.0.0.255 area 1
  network 192.168.2.0 0.0.0.255 area 0
  passive-interface lo0
  end




R3:::

router ospf 1
  network 192.168.35.0 0.0.0.255 area 2
  network 192.168.13.0 0.0.0.255 area 0
  network 192.168.3.0 0.0.0.255 area 0
  passive-interface lo0
  end

R4:::

router ospf 1
  network 192.168.24.0 0.0.0.255 area 1
  network 192.168.4.0 0.0.0.255 area 1
  passive-interface lo0
  end


R5::

router ospf 1
  network 192.168.35.0 0.0.0.255 area 2
  network 192.168.5.0 0.0.0.255 area 2
  passive-interface lo0
  end


OUTPUT::: {PING R5 FROM R4 }






CONFIGRE MD5 AUTHENTICATION BETWEEN R2 AND R4:::



R2:::
config t                        
ip ospf authentication message-digest
ip ospf authentication-key cisco123
end

no ping to r1::::




R4:::
config t                        
ip ospf authentication message-digest
ip ospf authentication-key cisco123
end

we will get ping to r1 because of neighbor will be up.



CONFIGRE AREA WISE MD5 AUTHENTICATION BETWEEN R2 AND R4:::


R2:::
config t
int s0/1
ip ospf authentication-key cisco123
exit
router ospf 1               
area 0  authentication message-digest
end

no ping to r1::::


R4:::
config t
int s0/1
ip ospf authentication-key cisco123
exit
router ospf 1               
area 0  authentication message-digest
end

we will get ping to r1 because of neighbor will be up.


CONFIGRE BROADCAST OSPF:::



R1::

  config t
  ip add 192.168.123.1 255.255.255.0
  no sh
  exit
  int lo0
  ip add 192.168.1.1 255.255.255.0
  no sh
  exit
R2::

  config t
  ip add 192.168.123.2 255.255.255.0
  no sh
  exit
  int lo0
  ip add 192.168.2.2 255.255.255.0
  no sh
  exit
R3::

  config t
  ip add 192.168.123.3 255.255.255.0
  no sh
  exit
  int lo0
  ip add 192.168.3.3 255.255.255.0
  no sh








BROADCAST  OSPF:::


R1::

Config t
router ospf 1
router-id 1.1.1.1
network 192.168.123.0 0.0.0.255
network 192.168.1.0 0.0.0.255
exit
R2::

Config t
router ospf 1
router-id 2.2.2.2
network 192.168.123.0 0.0.0.255
network 192.168.2.0 0.0.0.255
exit
R3::

Config t
router ospf 1
router-id 3.3.3.3
network 192.168.123.0 0.0.0.255
network 192.168.3.0 0.0.0.255
exit


CONFIGURING BGP (BORDER GATWAY PROTOCOL)


ASSIGN IP AND LOOPBACK ::
R1::::

config t
int s0/2
ip add 170.10.12.1 255.255.255.0
no sh
exit
int lo0
ip add 170.10.1.1 255.255.255.0
no sh
exit
int lo11
ip add 11.11.11.11 255.255.255.0
no sh
exit
R2::::

config t
int s0/0
ip add 170.10.23.2 255.255.255.0
no sh
exit
int s0/1
ip add 170.10.25.2 255.255.255.0
no sh
exit
int s0/2
ip add 170.10.12.2 255.255.255.0
no sh
exit
int lo0
ip add 170.10.2.2 255.255.255.0
no sh
exit





R3::::

config t
int s0/0
ip add 170.10.23.3 255.255.255.0
no sh
exit
int s0/1
ip add 170.10.34.3 255.255.255.0
no sh
exit
int lo0
ip add 170.10.3.3 255.255.255.0
no sh
exit



R5::::

config t
int s0/0
ip add 170.10.45.5 255.255.255.0
no sh
exit
int s0/1
ip add 170.10.25.5 255.255.255.0
no sh
exit
int lo0
ip add 170.10.5.5 255.255.255.0
no sh
exit
exit

R4::::

config t
int s0/0
ip add 170.10.45.4 255.255.255.0
no sh
exit
int s0/1
ip add 170.10.34.4 255.255.255.0
no sh
exit
int s0/2
ip add 170.10.46.4 255.255.255.0
no sh
exit
int lo0
ip add 170.10.4.4 255.255.255.0
no sh
exit


R6::::

config t
int s0/2
ip add 170.10.46.6 255.255.255.0
no sh
exit
int lo0
ip add 170.10.6.6 255.255.255.0
no sh
exit
int lo66
ip add 66.66.66.66 255.255.255.0
no sh
exit











OSPF FOR INTER COMMUNICATION BETWEEN R2, R3, R4, R5 IN AS 200:::

R2:::

config t
router ospf 1
network          170.10.23.0 0.0.0.255 area 0
network          170.10.25.0 0.0.0.255 area 0
network          170.10.2.0 0.0.0.255 area
exit

R4:::

config t
router ospf 1
network          170.10.34.0 0.0.0.255 area 0
network          170.10.45.0 0.0.0.255 area 0
network          170.10.4.0 0.0.0.255 area
exit

R3:::

config t
router ospf 1
network          170.10.23.0 0.0.0.255 area 0
network          170.10.34.0 0.0.0.255 area 0
network          170.10.3.0 0.0.0.255 area
exit

R5:::

config t
router ospf 1
network          170.10.45.0 0.0.0.255 area 0
network          170.10.25.0 0.0.0.255 area 0
network          170.10.5.0 0.0.0.255 area
exit




CONFIGURING EBGP BETWEEN R1 AND R2, R4 AND R6 DIFFERENT [[MAKING NEIGHBORSHIP BETWEEN R1 AND R2 & R4 AND R6]::

R1:::
router bgp 100
neighbor 170.10.12.2 remote-AS 200
exit

R4:::

router bgp 200
neighbor 170.10.46.6 remote-AS 300
exit
R2:::

router bgp 200
neighbor 170.10.12.1 remote-AS 100
exit
R6:::

router bgp 300
neighbor 170.10.46.4 remote-AS 200
exit







BRODCAST INTERNAL NETWORK FROM R1 TO R6 VIA BGP:::

R1:::

router bgp 100
network 11.11.11.0 mask 255.255.255.0
exit


R6:::

router bgp 300
network 66.66.66.0 mask 255.255.255.0
exit

VERIFY ::

sh ip bgp
sh ip route


CONFIGURE IBGP BETWEEB R2 AND R4::[MAKING NEIGHBOR RELATIONSHIP BETWEEN R2 AND R4]

R2:::

Router bgp 200
 neigshbor 170.10.4.4 remote-as 200
End
R4:::

Router bgp 200
 neighbor 170.10.2.2 remote-as 200
End

VERIFY::

Sh ip bgp summary

CONFIGURE IBGP BETWEEB R2 AND R4::[MAKING NEIGHBORS RELATIONSHIP BETWEEN R2 AND R4 AND IT WILL FORWARD DATA USING THEIR LOOPBACK ADDRESS]

R2::

Router bgp 200
Neighbor 170.10.4.4 update-source lo0 (loopback)
End
R4::

Router bgp 200
Neighbor 170.10.2.2 update-source lo0 (loopback)
End






CONFIGURE IBGP ROUTERS SEND E BGP N/W WITH UPDATE FOR THEM AS NEXT HOP:: [IT WILL MAKE THEM AS NEIGHBOR HOP FOR DIFFERENT HOP]::


R2::

Router bgp 200
Neighbor 170.10.4.4 next-hop-self
End
R4::

Router bgp 200
Neighbor 170.10.2.2 next-hop-self
End

OUTPUT:::: [YOY CAN FIND THIS IN ANY ROUTER]
R1:::

R6:::








No comments:

Post a Comment

T he primary difference is that  Linux  and  Unix  are two different Operating Systems though they both have some common commands. Let...